THE WOLF PACK BUILD FOR KODI 17 AND KODI 16.1-PACKED WITH LIVE TV AND RETRO GAMING


THIS BUILD IS COMPATIBLE WITH KODI 17 AND KODI 16.1. ANDROID DEVICES UNDER ANDROID VERSION 5.1 WILL NOT BE ABLE TO INSTALL KODI 17 …


Posted on: February 20, 2017, by : kodi1